SD card files not matching

Open discussion about WinMerge.

SD card files not matching

Postby goldeneye » Wed Jun 27, 2018 10:01 am

The scenario is this:
In Windows 10, copy a load of files from HDD to an SD card connected via USB adapter
Run Winmerge to check SD copy is OK, but differences are reported
Re-copy those files, sometime multiple times to eliminate any differences
Eject SD card gracefully and then re-insert once more
Winmerge again shows differences, even though at the last test there were none. Repeating the eject and insert, then re-testing can show different file differences, where new files appear and earlier differences are now gone.

It may at first glance appear to be an SD card issue, but the plot thickens:
All SD cards tried have the same issue (old, new, classes 4 through 10, plus micro versions)
Using another PC on Win 7, the issue is the same
Using a laptop's own card reader, the issue is the same

Copying the same files to a USB drive does not exhibit this problem.

Now, this is not a problem with Winmerge, but I just hoped you could shed some light on this. If I use Teracopy to copy the files, that software can verify files after the copy process and it also reports errors in the hash values (hence my use of Winmerge)
It also confirms what I've been seeing the last few years of using SD card in digital photography: when I copy from SD to HDD, some (approx 2%) of files get corrupted in some manner. Yet retrying the failed files may then work, or may never work.

The final killer is that I dug out an old, very slow XP system, and performing the same tests above *never* fails: the SD cards verify 100% every time.
goldeneye
 
Posts: 1
Joined: Wed Jun 27, 2018 9:44 am

Return to Open Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron