WinMerge folder comparison stops at specific files

Open discussion about WinMerge.

WinMerge folder comparison stops at specific files

Postby MPeti1 » Sat Jul 13, 2019 12:45 pm

Today I've ran into a problem when I tried to compare 2 paritions (they are mounted Macrium images).
WinMerge has stopped at the file named c:\Program Files\WindowsApps\microsoft.windowscommunicationsapps_16005.11425.20190.0_x64__8wekyb3d8bbwe\en-gb\locimages\offsym.ttf
I only noticed it after a lot of time went by, and then I restarted the comparison because a few days earlier I've also run into this issue, but this time it stopped here again. I opened Total Commander to see what's the problem, and I wasn't able to open, delete, or copy it because of permission (or read-lock, although I couldn't find handle to it) issues, nor to open the context menu of the file because tcmd would always crash. I've finally solved it by starting a cmd with System privileges and running del /f [path].
This is the first time WinMerge stopped at a file every single time I tried again scanning, but there were other occasions where for the next scan it was fine.
I think stopping at a file without giving a notification can be considered a bug, even because I wasn't able to close WinMerge by traditional means (only by killing the process).
Please could you do something about it? I think it would be the best if it would display a generic Windows error dialog, and at the same time it would continue the scan on the next files. Also, it would be good if I could try again comparing individual files when the scan has finished.
MPeti1
 
Posts: 1
Joined: Sat Jul 13, 2019 11:54 am

Return to Open Discussion

Who is online

Users browsing this forum: No registered users and 12 guests