Default "Compare as"

Open discussion about WinMerge.

Default "Compare as"

Postby KOHb » Tue Jun 02, 2020 4:33 pm

Hi
the files I compare a LOT use different extension (.pgm per say).
They are essentially text files.
When i compare them - the WinMerge compares them as XML and finds no differences.
Every time I have to compare those files (and with other extensions like .cod, etc. - but still plain text) - XML is default template.
So, every time I have to go to File->RecompareAs->Text to get to what I need.
And I'm comparing lots of files, so it's very annoying and counterproductive.

Is there a way to set default to use Text template instead of XML?

Or other way to avoid XML default comparing.

Thanks.
KOHb
 
Posts: 1
Joined: Tue Jun 02, 2020 4:24 pm

Re: Default "Compare as"

Postby mantiss » Fri Aug 21, 2020 11:51 am

Hi,

I ran into a similar problem after accidentally left a dangling semi-colon {;} when I updated my compare binary option.
Check your entry in 'Binary File Pattern' text field under the File | Options | Categories | Compare | Binary sub menu.

In my case I initially updated to:

*.bin;*.frx;

and fixed by removing semi-colon at the end:

*.bin;*.frx
mantiss
 
Posts: 1
Joined: Fri Aug 21, 2020 11:40 am

Re: Default "Compare as"

Postby HiramAbiff » Mon Sep 14, 2020 2:51 pm

This didn't work for me. I would also like to see the option to set defaults to "text". If it's already an option, I can't find it. It seems odd to assume that any comparison you want to make would default to "xml".
HiramAbiff
 
Posts: 1
Joined: Fri Sep 11, 2020 4:47 pm


Return to Open Discussion

Who is online

Users browsing this forum: Bing [Bot] and 11 guests