WinMerge 2.14.0.0 and 7-zip 9.20

Open discussion about WinMerge.

WinMerge 2.14.0.0 and 7-zip 9.20

Postby nedm » Wed Feb 13, 2013 7:14 pm

I have just installed WinMerge 2.14.0.0 on a virgin Windows 7 machine, and follwed that by installing 7-zip 9.20. Nevertheless, WinMerge's Archive support is disabled, saying "Merge7z920U.dll: The specified module could not be found". 7-Zip is installed in C:\Program Files (x86)\7-Zip, which contains 2 DLLs: 7z.dll and 7-zip.dll, but not Merge7z920U.dll. How can I get Archive Support enabled?
Thanks,
Ned
nedm
 
Posts: 1
Joined: Wed Feb 13, 2013 6:08 pm

Re: WinMerge 2.14.0.0 and 7-zip 9.20

Postby click-click » Fri Feb 15, 2013 4:26 pm

I noticed too that the previous version 2.12.4 installed archive support whereas v2.14 does not. I also would be interested
how to enable archive support. I have 7-zip installed.
click-click
 
Posts: 4
Joined: Mon Feb 11, 2013 12:41 pm

Re: WinMerge 2.14.0.0 and 7-zip 9.20

Postby click-click » Fri Feb 15, 2013 5:16 pm

Nevermind, I found the information how to enable archive support in the help.chm
click-click
 
Posts: 4
Joined: Mon Feb 11, 2013 12:41 pm

Re: WinMerge 2.14.0.0 and 7-zip 9.20

Postby teatime » Thu Aug 29, 2013 4:03 am

Hello I have the same problem.
9.2 7-zip and winmerge 2.14.0.
What I have to do that I can use the archive functions?

I hope that anyone can help me, thanks.
teatime
 
Posts: 1
Joined: Thu Aug 29, 2013 3:57 am

Re: WinMerge 2.14.0.0 and 7-zip 9.20

Postby Biep » Sun Mar 23, 2014 9:20 pm

The same here. WinMerge does find Merge7z920[U].dll in Windows\system32, but that doesn't do the trick. I have put Merge7z465U.dll in the WinMerge folder, but that doesn't seem to help either.

If someone could write a small guide for dummies on how to get this working, I'd be very thankful!
Biep
 
Posts: 1
Joined: Sun Mar 23, 2014 9:12 pm

Re: WinMerge 2.14.0.0 and 7-zip 9.20

Postby jtuc » Sun Apr 06, 2014 11:34 am

Related thread: viewtopic.php?f=4&t=315
jtuc
Developer
 
Posts: 182
Joined: Sat Dec 20, 2008 11:05 am

Re: WinMerge 2.14.0.0 and 7-zip 9.20

Postby onnward » Tue May 24, 2016 1:55 pm

Dummies Guide to getting Archive Support working on WinMerge

Install WinMerge - I'm using version 16.02 at the time of this posting

Install 7-zip 9.20 - http://www.7-zip.org/download.html
NOTE: Install 7-Zip version 9.20 - WINMERGE WILL NOT WORK WITH ANYTHING NEWER

Install Merge7zInstaller0028-465-920.exe - Can be found under Build 0028, https://sourceforge.net/projects/winmerge/files/7-zip-plugin/DllBuild%200028/

Open WinMerge, Options, Archive Support

Add a tick in the 'Enable archive file support'

Select the 'User stand-alone 7-zip if available'

Restart WinMerge

As per other posts, this information is contained within the WinMerge help file although the instructions are far from clear and crucially it does not mention that the archive option will not work with any version of 7-Zip newer than version 9.20 installed.
onnward
 
Posts: 1
Joined: Tue May 24, 2016 1:29 pm


Return to Open Discussion

Who is online

Users browsing this forum: Bing [Bot] and 3 guests