WinMerge Requirements

Main development forum.

WinMerge Requirements

Postby gerundt » Tue Feb 10, 2009 9:20 am

I think we should add the WinMerge Requirements to our Download page.

So, what are the requirements?
  • Microsoft Windows 98/2000/XP/2003/Vista/2008
  • ...
  • Admin rights?
gerundt
Site Admin
 
Posts: 193
Joined: Wed Sep 24, 2008 8:47 am
Location: Germany

Re: WinMerge Requirements

Postby kimmov » Tue Feb 10, 2009 3:05 pm

Good question!

Couple of answers:
  • WinMerge is very much self-contained so that we don't need any external libraries or frameworks. We'll install all needed libraries with installer.
  • Admin rights are needed by the installer for installing shell extension. It would be a good TODO-item for somebody to modify installer so that it can be run without admin privileges and just skips shell extension installation then.
  • If one installs from .zip file then no admin privileges are needed.
  • OS.. Well, all I know it works in Win XP and Vista :? I haven't heard anybody of regular people around to test with other versions. There are some bug reports but nothing like "does not work in Win98" -category.
  • WinXP 64-bit works (I've tested) and Vista 64-bit should work (no bug reports). No idea about W2008. Windows 7 probably works.
  • There is a bug report about Win7 64-bit. I've just installed Win7 64-bit to virtual machine and will look at it..
kimmov
 
Posts: 562
Joined: Thu Sep 11, 2008 8:51 pm
Location: Finland

Re: WinMerge Requirements

Postby gerundt » Tue Feb 10, 2009 3:18 pm

What are in the "Runtimes" packages, we have currently at the download page? The "Visual Studio Runtimes"? If we skip the runtime packages with WinMerge 2.12, we should name this runtimes...
gerundt
Site Admin
 
Posts: 193
Joined: Wed Sep 24, 2008 8:47 am
Location: Germany

Re: WinMerge Requirements

Postby kimmov » Tue Feb 10, 2009 3:34 pm

gerundt wrote:What are in the "Runtimes" packages, we have currently at the download page? The "Visual Studio Runtimes"? If we skip the runtime packages with WinMerge 2.12, we should name this runtimes...

I'm not removing them from installer.

But those who install WinMerge from .zip and for some reason don't yet have those runtime files have to download them from MS or other download site. Needed runtime version depends on VS version used. VS2003 requires runtimes version 7.1, VS2005 version 8.0 and VS2008 version 9.0.
kimmov
 
Posts: 562
Joined: Thu Sep 11, 2008 8:51 pm
Location: Finland


Return to Developers

Who is online

Users browsing this forum: No registered users and 2 guests